Client autostarten

Alle Fragen rund um die Sicherungsklienten.
Antworten
rolandg
Beiträge: 9
Registriert: 17.12.2014, 14:04

Client autostarten

Beitrag von rolandg » 20.04.2015, 13:30

Nach einem Reboot eines Mail-Servers auf dem ein SEP-Client installiert ist, wurde letzterer nicht automatisch gestartet.

Bei einem SEP-Server würde man lt. Handbuch folgendes machen:

root:/opt/sesam/bin/sesam# ./sm_setup set_reboot

Der Befehl hat auf besagtem Mailserver die folgende Ausgabe geliefert:
Finished successfully in 0 second(s)

Passt das jetzt schon?
Kann man prüfen, ob das passt ohne den Server neu zu starten?

TIA,
Roland.

jgebhardt
Beiträge: 189
Registriert: 15.09.2009, 16:33

Re: Client autostarten

Beitrag von jgebhardt » 20.04.2015, 15:46

Hallo,

nach der Installation wird der Client automatisch im runlevel 3 und 5 gestartet.

Bitte mal nachsehen mit "chkconfig -l" ob der Sesam Dienst auf autostart steht.

Ob der Client läuft kann man mit "/opt/sesam/bin/sesam/sm_main status" überprüfen.

Jens

rolandg
Beiträge: 9
Registriert: 17.12.2014, 14:04

Re: Client autostarten

Beitrag von rolandg » 21.04.2015, 07:29

Hi,

chkconfig -l liefert:
sesam 0:off 1:off 2:on 3:on 4:off 5:off 6:off

Das war aber schon vorher so eingestellt und hat nicht funktioniert.

jgebhardt
Beiträge: 189
Registriert: 15.09.2009, 16:33

Re: Client autostarten

Beitrag von jgebhardt » 21.04.2015, 08:48

Hallo,

der Client startet nur im runlevel 2 und 3 automatisch. Läuft der Server im runlevel 3 ?

Übrigens ist runlevel 2 und 3 eine sehr ungewöhnliche Kombination, das sieht nach manuellem Eingriff aus.

Wenn ja (runlevel 3) ist zu klären, warum der Client nicht automatisch startet. Hilfreich sind an dieser Stelle /var/log/messages und /var/opt/sesam/var/log/lgc/sm_main_<datum>.* . Hier sollte zu finden sein, warum der Client nicht startet.

Läßt sich der Client mit der Hand starten ( /opt/sesam/bin/sesam/sm_main start ) ?

Jens

rolandg
Beiträge: 9
Registriert: 17.12.2014, 14:04

Re: Client autostarten

Beitrag von rolandg » 21.04.2015, 15:42

Der Server läuft im Runlevel 2.
Von Hand lässt er sich starten - das ist kein Problem.

Hier die Sesam sm_main.log vom besagten Tag, an dem der Dienst nicht startete:

Code: Alles auswählen

2015-04-18 18:29:20: sm_main[5472] started
2015-04-18 18:29:20: Arguments: /opt/sesam/bin/sesam//sm_main start
2015-04-18 18:29:21: qm                 : offline
2015-04-18 18:29:23: sm_qm: 
2015-04-18 18:29:23: sm_qm: 
2015-04-18 18:29:23: db                 : unused
2015-04-18 18:29:23: passd              : unused
2015-04-18 18:29:23: sms                : unused
2015-04-18 18:29:23: stpd               : unused
2015-04-18 18:29:23: ctrl               : offline
2015-04-18 18:29:23: /opt/sesam/bin/sesam/sm_qm submit sesam 18:29 2015-04-18 1  ctrl /opt/sesam/bin/sesam/sm_ctrld_main
2015-04-18 18:29:23: sm_qm: 
2015-04-18 18:29:23: ctrl               : offline
Dann zwei Tage später:

Code: Alles auswählen

2015-04-20 10:47:41: sm_main[8333] started
2015-04-20 10:47:41: Arguments: /opt/sesam/bin/sesam//sm_main status
2015-04-20 10:47:41: qm         [  5483]: online
2015-04-20 10:47:41: db                 : unused
2015-04-20 10:47:41: passd              : unused
2015-04-20 10:47:41: sms                : unused
2015-04-20 10:47:41: stpd               : unused
2015-04-20 10:47:41: ctrl               : offline
2015-04-20 10:47:41: sshd               : offline
2015-04-20 10:47:41: sepuler            : unused
2015-04-20 10:47:41: rmi                : unused
2015-04-20 10:47:41: ui                 : unused
2015-04-20 10:47:41: sds                : unused
2015-04-20 10:47:47: sm_main[8487] started
2015-04-20 10:47:47: Arguments: /opt/sesam/bin/sesam//sm_main start
2015-04-20 10:47:47: qm         [  5483]: online
2015-04-20 10:47:47: sm_qm: 
2015-04-20 10:47:47: sm_qm: 
2015-04-20 10:47:47: db                 : unused
2015-04-20 10:47:47: passd              : unused
2015-04-20 10:47:47: sms                : unused
2015-04-20 10:47:47: stpd               : unused
2015-04-20 10:47:47: ctrl               : offline
2015-04-20 10:47:47: /opt/sesam/bin/sesam/sm_qm submit sesam 10:47 2015-04-20 1  ctrl /opt/sesam/bin/sesam/sm_ctrld_main
2015-04-20 10:47:47: sm_qm: 
2015-04-20 10:47:47: Found job:   2    ctrl                  1                   8503   10:47 2015-04-20

2015-04-20 10:47:47: ctrl       [  8503]: online
2015-04-20 10:47:47: sshd               : offline
2015-04-20 10:47:47: /opt/sesam/bin/sesam/sm_qm submit sesam 10:47 2015-04-20 1  sshd /opt/sesam/bin/sesam/sm_sshd
2015-04-20 10:47:47: sm_qm: 
2015-04-20 10:47:48: Found job:   3    sshd                  1                   8513   10:47 2015-04-20

2015-04-20 10:47:48: sshd       [  8513]: online
2015-04-20 10:47:48: sepuler            : unused
2015-04-20 10:47:48: rmi                : unused
2015-04-20 10:47:48: ui                 : unused
2015-04-20 10:47:48: sds                : unused
2015-04-20 13:51:50: sm_main[20402] started
2015-04-20 13:51:50: Arguments: /opt/sesam/bin/sesam//sm_main status
2015-04-20 13:51:50: qm         [  5483]: online
2015-04-20 13:51:50: db                 : unused
2015-04-20 13:51:50: passd              : unused
2015-04-20 13:51:50: sms                : unused
2015-04-20 13:51:50: stpd               : unused
2015-04-20 13:51:50: Found job:   2    ctrl                  1                   8503   10:47 2015-04-20

2015-04-20 13:51:50: ctrl       [  8503]: online
2015-04-20 13:51:50: Found job:   3    sshd                  1                   8513   10:47 2015-04-20

2015-04-20 13:51:50: sshd       [  8513]: online
2015-04-20 13:51:50: sepuler            : unused
2015-04-20 13:51:50: rmi                : unused
2015-04-20 13:51:50: ui                 : unused
2015-04-20 13:51:50: sds                : unused
2015-04-20 13:52:00: sm_main[20546] started
2015-04-20 13:52:00: Arguments: /opt/sesam/bin/sesam//sm_main status
2015-04-20 13:52:00: qm         [  5483]: online
2015-04-20 13:52:00: db                 : unused
2015-04-20 13:52:00: passd              : unused
2015-04-20 13:52:00: sms                : unused
2015-04-20 13:52:00: stpd               : unused
2015-04-20 13:52:00: Found job:   2    ctrl                  1                   8503   10:47 2015-04-20

2015-04-20 13:52:00: ctrl       [  8503]: online
2015-04-20 13:52:00: Found job:   3    sshd                  1                   8513   10:47 2015-04-20

2015-04-20 13:52:00: sshd       [  8513]: online
2015-04-20 13:52:00: sepuler            : unused
2015-04-20 13:52:00: rmi                : unused
2015-04-20 13:52:00: ui                 : unused
2015-04-20 13:52:00: sds                : unused

jgebhardt
Beiträge: 189
Registriert: 15.09.2009, 16:33

Re: Client autostarten

Beitrag von jgebhardt » 21.04.2015, 16:21

Hallo,

ist der Client überhaupt schon einmal automatisch gestartet ?

Vermutlich nicht, da die default runlevel für den autostart nur 3 und 5 sind.

bitte mal die /etc/init.d/sesam editieren.

### BEGIN INIT INFO
# Provides: sesam
# Required-Start: $local_fs $remote_fs $network
# X-UnitedLinux-Should-Start: $named $time postgresql ypclient dhcp radiusd
# Required-Stop: $local_fs $remote_fs $network
# X-UnitedLinux-Should-Stop:
# Default-Start: 3 5
# Default-Stop: 0 1 2 6
# Short-Description: SEPsesam
# Description: Start SEPsesam backup client
### END INIT INFO

Bei
# Default-Start: 2 3 5
und
# Default-Stop: 0 1 6
eintragen.

Ausserdem aus /etc/init.d/rc3.d/ die K50sesam und S50sesam Scripte nach /etc/init.d/rc2.d kopieren.

Vorher natürlich /etc/init.d/sesam "sichern" und dann die Änderungen machen und testen.

Wenn das funktionieren sollte, bitte daran denken, das die /etc/init.d/sesam bei jedem Client Update (vermutl.) wieder überschrieben wird.

Jens

rolandg
Beiträge: 9
Registriert: 17.12.2014, 14:04

Re: Client autostarten

Beitrag von rolandg » 21.04.2015, 17:12

Hi,

nein, vermutlich ist der Client nie automatisch gestartet.

Ich habe das sesam-File editiert, danke für den Hinweis.
Ich hatte die Datei offen, aber durch das Syntax-Highlighting den vermeintlichen Kommentar leider überlesen.

Die Kill und Start-Skripte konnte ich leider nicht finden.
Das Ganze läuft auf UCS 4.0-0, da ist das wohl anders gelöst.

LG,
Roland.

jgebhardt
Beiträge: 189
Registriert: 15.09.2009, 16:33

Re: Client autostarten

Beitrag von jgebhardt » 22.04.2015, 07:47

Hallo,

ich habe noch mal bei UCS Server nachgesehen, dort sind die K und S Scripte, K01sesam und S99sesam . In meinem Fall waren diese sogar schon in /etc/init.d/rc2.d/ mit drin. Ausserdem muss ich mich korrigieren, in den /etc/init.d/rcx.d/ Verzeichnissen sind die Scripte nur Verlinkt, d.h. nicht kopieren sondern verlinken, falls nicht vorhanden.

Mindestens in /etc/init.d/rc3.d und rc5.d sollten die Links drin sein. Wenn dem nicht so ist, ist verm. schon bei der Installation was schiefgelaufen.

Ein kurzes Feedback ob die Sache nach der Anpassung funktioniert wäre nett.

Jens

rolandg
Beiträge: 9
Registriert: 17.12.2014, 14:04

Re: Client autostarten

Beitrag von rolandg » 22.04.2015, 13:50

Hi,

die Kill/Start-Skripte liegen unter /etc/rc2.d und die entsprechenden Links waren schon vorhanden.
Somit sollte die Anpassung des sesam-Config-Files schon ausreichen.

Ich kann den Kunden bitten mich zu informieren ob alles geklappt hat, wenn er das nächste Mal neu startet - wird aber sicherlich etwas dauern. :-)

Vielen Dank!

jgebhardt
Beiträge: 189
Registriert: 15.09.2009, 16:33

Re: Client autostarten

Beitrag von jgebhardt » 22.04.2015, 13:54

Hallo,

danke für die Rückantwort. Die Info ob es funktioniert wäre wichtig, falls noch mal jemand anderes über das Problem stolpert.

Danke

Jens

rolandg
Beiträge: 9
Registriert: 17.12.2014, 14:04

Re: Client autostarten

Beitrag von rolandg » 23.04.2015, 08:17

Hi nochmal,

ich habe jetzt noch eine interessante Info vom Kunden bekommen:

Er hat auch zwei andere Server (ein weiteres UCS und ein Debian) und bei diesen ist der Client automatisch gestartet, obwohl die Einstellung im sesam-File gleich ist:
# Default-Start: 3 5
# Default-Stop: 0 1 2 6

Diese Server laufen auch per default im Runlevel 2.
:-(

jgebhardt
Beiträge: 189
Registriert: 15.09.2009, 16:33

Re: Client autostarten

Beitrag von jgebhardt » 23.04.2015, 09:26

Hallo,

dann bin ich mit meinem Latein am Ende. Eventuell den Clienten einfach mal deinstallieren und völlig neu installieren. Sonst hilft nur ein Ticket beim SEP Support.

Jens

Antworten