Backup error: LoadLibrary() call failed for: [vss.dll]]

Here you can write your Problems with Backups.

Moderator: sepma

Post Reply
elcake
Posts: 4
Joined: June 13th, 2013, 9:11 am
Spam Stop: No
SEP sesam: Software

Backup error: LoadLibrary() call failed for: [vss.dll]]

Post by elcake » December 11th, 2013, 8:17 am

Good Morning,

System Information:

SEP Server: Windows 2008 R2
SEP Server version: 4.2.2.18
SEP Client: Windows 2012
Problem short: System backup to tape not working

Problem description:
SEP Server is failing to execute a path backup for this client. An error message is thrown:
FINISH ERROR Error: Problem while loading dynamic link library: [WIN32 API error: 1114 - A dynamic link library (DLL) initialization routine failed. LoadLibrary() call failed for: [vss.dll]].
This problem occurs randomly 1-3 times a week. The backups are working fine, sometimes a couple days in a row, until the error shows up again.

Another problem with this client is that SEP server has a hard time browsing the client's disks. The GUI freezes for 2 minutes until the ressources are finally shown. Checking the access seems fine tho:
I005-HOSTS SESAM client is already installed on client, access is valid.

Restarting the SEP service on the client seems to have not much of an effect. Reeinstalling the software on the client seems to be the only solution (at least for a couple of days).

Tried Solutions:

- Reeinstalling SEP on client
- Restarting services
- Reconfiguration of the backup task (changing path, VSS ...)
- Path backup without VSS seems to work

Related Problems:
I opened the same issue a few months back when this error first appeared. I was soothened that windows 2012 was not supported by SEP 4.0.x.
http://forum.sep.de/en/viewtopic.php?f=12&t=828
But now, we installed the latest versions on server and client but the problem still exists.

Does anyone have an idea how to fix this error?

jgb
Posts: 55
Joined: June 27th, 2011, 11:11 am
Spam Stop: No
SEP sesam: Software

Re: Backup error: LoadLibrary() call failed for: [vss.dll]]

Post by jgb » December 11th, 2013, 4:27 pm

Hi,

if an dll cannot be initialized, most time an antivirus solution is the "bad boy".
If you have running antivirus, please try to disable the antivirus software during the backup.

Also have a look in the event log of the client, if you see an error or message when the error occur.

The cause for the slow browse issue can be a name resolution problem or also the antivirus solution.

JGE

elcake
Posts: 4
Joined: June 13th, 2013, 9:11 am
Spam Stop: No
SEP sesam: Software

Re: Backup error: LoadLibrary() call failed for: [vss.dll]]

Post by elcake » December 12th, 2013, 7:37 am

Good Morning jgb,

Thank you for your reply.
We do not have an antivirus on this client (or any other protection software)
I have checked the event viewer and I did not see any warning or errors that could be related to SEP or vss and there are no recorded events around the schedule time of the backups.

The DNS-resolution is fine. The clients are listed in the /etc/hosts locally on the backup server. So there is no DNS-server that can cause any troubles.

The strange thing seems to be that the backups are working after a re-installation of the SEP client or when launching the backups without VSS (which is not possibly for a system state backup)

jgb
Posts: 55
Joined: June 27th, 2011, 11:11 am
Spam Stop: No
SEP sesam: Software

Re: Backup error: LoadLibrary() call failed for: [vss.dll]]

Post by jgb » December 13th, 2013, 10:56 am

Hello,

please check the VSS configuration of the client.

vssadmin list writers -> check if all writer OK (for troubleshooting do this every day to be sure that the writers OK)

vssadmin list shadows -> shows existing VSS copies

vssadmin list shadowstorage -> shows the reserved space and the available space for VSS

Set the reserved space for VSS Snapshots to unlimited.

vssadmin resize shadowstorage ( pressEnter for correct syntax )

It seems that some values to low or to high or that any other process(es) involved in that issue.

Please open a support ticket at support@sep.de .

JGB

Post Reply