Installation failure because of underscore in hostname

This is for the remaining stuff.

Moderator: sepma

Post Reply
twouters
Posts: 1
Joined: December 2nd, 2010, 5:18 pm
Spam Stop: No
SEP sesam: Software

Installation failure because of underscore in hostname

Post by twouters » December 2nd, 2010, 5:29 pm

Hi,

I've been having some issues with installing SEP Sesam server on a Windows 2008 R2 64bit server.

The first problem I encountered was that the installations failed as long as I had IPv6 enabled.
I got a popup while running the installer that said: "SM_SETUP Warning: Could not start SM_MAIN. Restart manually."
I can't remember the exact error that the installer showed in its status bar, but I haven't got it since I disabled IPv6 on the server. (Could be a coincidence though since I had to reboot the server to disable IPv6)

Now I can't install SEP because there's an underscore in my hostname. I'm not really planning to change the hostname since all of the servers in this network have the same naming scheme.
I got the same popup as before and the error reported in the status bar is: "(0/49) Invalid hostname 'MY_HOSTNAME' (Includes '_')"

Is there a reasoning behind this or is it possible to somehow allow underscores in hostnames?

ossi1001
Posts: 77
Joined: May 15th, 2009, 10:41 am

Re: Installation failure because of underscore in hostname

Post by ossi1001 » December 17th, 2010, 10:55 am

Hy,

as far as I know, this problem just occurs on sesam Server due to the RMI (remote management interface), which uses Java and some versions of Java doesn't support hostnames with underscores. On clients this problem should not occur, because no Java is needed.
You could try to add a second hostname (e.g. in hosts-file) with a seperated IP address and retry the installation.

Greetings, ossi1001

Post Reply