Page 1 of 1

Upgrade to 3.6.4-34 for srv but wont allow GUI or CLI to upg

Posted: September 8th, 2011, 3:15 am
by deyjvu

I have upgraded the server to 3.6.4-34 ready to upgrade eventually to 4.0 but once I upgraded the server to 3.6.4-34 and it reported no errors, it finished successfully now I can't upgrade anything else. When I tried to upgrade the GUI and the CLI both of these fail with
# rpm -Uvh sesam_gui-3.6.4-34.rhel5.i386.rpm
error: Failed dependencies:
sesam_srv conflicts with sesam_gui-3.6.4-34.rhel5.i386
sesam_gui conflicts with sesam_srv-3.6.4-34.rhel5.i386

The first upgrade was successful as shown:
# rpm -qa |grep sesam

Why wont it allow me to upgrade to this new version for the gui? Why is it conflicting with itself?

Re: Upgrade to 3.6.4-34 for srv but wont allow GUI or CLI to

Posted: September 8th, 2011, 8:29 am
by deyjvu
Answered my own question... but it may help others.

Didn't realise that the upgrade of the server includes the upgrade of the gui and the client so I did not have to do anything extra - would be nice if this was documented somewhere :-).

Then doing the restart I tried to use the sm_start script in /opt/sesam/bin/sesam but this didn't work. Using the /etc/rc.d/init.d/sesam start command did start everything up and all is now working on 3.6.4-34. Phew.